Technical Support Phone and Chat Coverage

Incident Report for Alida

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 12:31 EDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2026 - 08:57 EDT

Investigating

Hi all,

Please note that Technical Support will be unavailable through the Live Chat and Phone channels on 6/25 PM from 6 PM PST to 10 PM PST and on 6/26 from 6 PM PST to 10 PM PST.

Our Technical Support team can be contacted via email by submitting your inquiry to support@alida.com.

Thank you for your understanding.
Posted Jun 25, 2026 - 19:00 EDT
This incident affected: AP2 (Technical Support Coverage) and AP3 (Technical Support Coverage).