NA2 Standard Reports Not Loading

Incident Report for Alida

Resolved

The issue related to accessing Standard Reports in NA2 has been resolved. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Oct 07, 2025 - 17:48 EDT

Investigating

We are currently investigating an issue in which Standard Reporting is inaccessible in the NA2 pod. As a workaround, Modern Reports can be utilized to view report data. Thank you for your patience while we work to resolve this issue.
Posted Oct 07, 2025 - 16:54 EDT
This incident affected: NA2 (Surveys).