Power Surveys Inaccessible in EU1

Incident Report for Alida

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 19:52 EDT

Investigating

We are currently investigating an issue in which Power Surveys are inaccessible in the EU1 pod. This issue impacts the ability to access Power Surveys via the platform and respondents from completing surveys authored in Power Surveys. Thank you for your patience while we work to resolve this issue.
Posted Jul 15, 2026 - 18:29 EDT
This incident affected: EU1 (Power Surveys).