Distribution Issues in NA2
Incident Report for Alida
Resolved
Our team has successfully identified and addressed the issue affecting the distribution of invitations within the NA2 pod. We appreciate your patience during the resolution process and apologize for any inconvenience this may have caused.
Posted Sep 03, 2024 - 16:21 EDT
Investigating
We are currently addressing an issue that may impact the distribution of invitations within the NA2 pod. Our team is actively working to resolve this matter as swiftly as possible. We appreciate your patience and apologize for any inconvenience this may cause.
Posted Sep 03, 2024 - 16:07 EDT
This incident affected: NA2 (Surveys).