EU 1 - Degraded performance in the platform

Incident Report for Alida

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 12:02 EST

Update

We are continuing to investigate this issue.
Posted Jan 07, 2026 - 10:26 EST

Investigating

We are currently experiencing issues in the platform due to degraded performance the EU 1 region and are working to resolve this issue as soon as possible.
Posted Jan 07, 2026 - 08:37 EST
This incident affected: EU1 (Surveys, Power Surveys).