Issue with server responding for Power Surveys

Incident Report for Alida

Resolved

This incident has been resolved
Posted May 13, 2026 - 21:00 EDT

Update

We have found a resolution for the issue and expect this to be resolved within 2 hours
Posted May 13, 2026 - 19:56 EDT

Update

We are continuing to investigate this issue.
Posted May 13, 2026 - 19:56 EDT

Investigating

There is currently an issue affecting server responding for Power Surveys. We are investigating this and working towards resolving the issue
Posted May 13, 2026 - 18:57 EDT
This incident affected: NA1 / AP1 (Power Surveys), NA2 (Power Surveys), EU1 (Power Surveys), EU2 (Power Surveys), AP2 (Power Surveys), and AP3 (Power Surveys).