Performance Issues in NA2
Incident Report for Alida
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 10:12 EST
Investigating
Some users may experience severe latency/performance issues when trying to load certain pages in NA2 communities, especially the Surveys page, or specific surveys. We are currently investigating this incident.
Posted Nov 18, 2021 - 07:59 EST
This incident affected: NA2 (Insight Community).