Help Center is Currently Inaccessible
Incident Report for Alida
Resolved
This incident has been resolved.
Posted May 11, 2021 - 21:13 EDT
Identified
We have identified an issue that is preventing customers from accessing Alida Help Center. We've reached out to our third party vendor to resolve this issue. If you require technical assistance, you can contact the Technical Support Team by emailing support@alida.com.
You may expect longer response times and if you have any urgent technical issues please call the support phone line.
Posted May 11, 2021 - 19:46 EDT
Update
We have identified an issue that is preventing customers from accessing Alida Help Center. We've reached out to our third-party vendor to resolve this issue. If you require technical assistance, you can contact the Technical Support Team by emailing support@alida.com.

You may expect longer response times and if you have any urgent technical issues please call the support phone line.
Posted May 11, 2021 - 19:45 EDT
Update
We are continuing to investigate this issue.
Posted May 11, 2021 - 18:17 EDT
Investigating
We have identified an issue that is preventing customers from accessing Alida Help Center. If you require technical assistance, you can contact the Technical Support Team by emailing support@alida.com
Posted May 11, 2021 - 18:13 EDT
This incident affected: Help Center & Alida Academy.